Jira Cloud Migration Assistant (JCMA) Error: Please remove these share permissions and re-create them after migration

Platform Notice: Cloud, Server, and Data Center - This article applies equally to all platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

When running a migration plan to migrate Jira Server projects to Jira Cloud, the Jira Cloud Migration Assistant (JCMA) plugin may report errors regarding share permissions tied to migrating projects. 

Environment

Jira Server with Jira Cloud Migration Assistant 1.0 and higher

Diagnosis

2021-01-05 04:23:44.202 ERROR ALPHA project-export Board 'ACME BOARD' is shared to users of other projects: BETA. Please remove these share permissions and re-create them after migration.

In this example error block, project ALPHA migration has failed because board: ACME Board is also shared to the BETA Project. 

Cause

This error is thrown because boards associated to projects included in a migration plan are shared to other projects that are not a part of the migration plan. Since this is a dependency issue, JCMA alerts you to the problem and does not proceed with the project migration. 

Solution

  1. Go to the board mentioned in the error message

  2. Click on Board → Configure

  3. Click on General and Filter → “Edit Filter Shares”

  4. Remove users or groups that were referenced in the error log from the affected board

  5. Re-attempt to migrate the attached project through the Jira Cloud Migration Assistant

Keep in mind that to make these changes, Jira Server Admins will need the Create Shared Objects global permission in order to make config changes to any Shared Filters.  If even after assigning the needed permission the admin still doesn’t display the Edit Filters Share link, the filter may belong to another user and the admin may need to transfer ownership of the filter to themselves before attempting to remove it from the board. You can change ownership of the board by following the documentation here: Changing the ownership of a shared filter.

Other Notes

For troubleshooting other JCMA related errors, please refer to this documentation for help Troubleshooting errors and non-migrated entities with the Jira Cloud Migration Assistant




Last modified on Aug 12, 2021

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.