Jira Cloud REST API limits the number of changelogs returned.
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Problem
Jira Cloud REST API endpoints return a limited number of changelog results, when expand=changelog
parameter is used in eligible requests. In particular this impacts the following endpoints:
Cause
As it was announced in the Change Notice - changelogs are now limited to the 100 most recent items when requested as expand
parameter of the REST API request. Note, that these now limited changelogs are ordered by date, starting from newest (descending) in order to provide the most relevant issue changes.
Resolution
In order to get full history of changes for an individual issue use dedicated /rest/api/2/issue/{issueIdOrKey}/changelog endpoint. Note, that the response will be paged and results will be ordered by date, starting from the oldest (ie. ascending).