JIRA Core date picker generates the error JIRA Calendar does not currently support your language

Platform Notice: Cloud and Data Center - This article applies equally to both cloud and data center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Problem

Trying to specify a date using the Date Picker within an Issue Screen generates the error, "The JIRA Calendar does not currently support your language.".

Diagnosis

This error only affects certain users - it is not platform or browser-specific.

Cause

  1. The "Language Preferences" are set to an invalid option. As an example, users may see a -1 for their Language:

(Auto-migrated image: description temporarily unavailable)

With Jira Data Center you can run the following database query to see what users have an invalid Language set on their profiles. This query was written for PostgreSQL and may require changing depending on the DBMS used.

1 select u.user_key, PROPERTY_KEY, propertyvalue from propertyentry pe join app_user u on u.id = pe.entity_ID join propertystring ps on ps.id = pe.id and property_Key like '%locale%';

2. The "Language Preferences" are set to a language that is missing the calendar .js files JRASERVER-30789 - Add language support to JIRA Calendar Plugin.

Solution

Resolution

    1. Log into the instance with the affected user and view their Profile Settings (Click on the User's Profile Icon in the Upper Right > Profile).

    2. Click on the Edit Icon (

      (Auto-migrated image: description temporarily unavailable)

      ) next to Preferences.

    3. In this window, re-select your language from the Language Dropdown and click Update.

  1. .js files need to be added as mentioned in Translating JIRA (Translating the javascript calendar popup tool section)

Updated on April 2, 2025

Still need help?

The Atlassian Community is here for you.