JIRA fails to assign to CC field user
Symptoms
Using a mail handler set up to Auto Assign to CC, one or more users do not get assigned when an Issue is created with them in CC field.
Diagnosis
This issue does not report in the logs. To diagnose this issue, find a user that has the problem, and use the User Browser to search for users with an identical e-mail address.
Cause
When two users share the same email address but only one of them can be the assignee for the Issue, JIRA is not able to determine the correct assignee.
Workaround
Ensure that there are no two users that share the same email address.