Jira fails to create or update tickets via email due to incorrect Email Finger Print
Platform Notice: Server, Data Center, and Cloud By Request - This article was written for the Atlassian server and data center platforms but may also be useful for Atlassian Cloud customers. If completing instructions in this article would help you, please contact Atlassian Support and mention it.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Do note that Atlassian do not support customization as described on the documentation as outlined in our Atlassian Support Offerings. Please only try if you are confident on doing so and we strongly encourage customers to perform the check on test environment first before applying to production.
Problem
The below message appears at atlassian-jira.log. The message you are seeing comes from AbstractMessageHandler in the jira-mail-plugin. In case if JIRA receives an email from another JIRA instance. It means JIRA sends X-JIRA-FingerPrint included in the mail header.
Received message with another JIRA instance's fingerprint
Cause
This feature is to detect loop and avoiding it.
See the Email class:
public class Email extends com.atlassian.mail.Email
{
/**
* JIRA's custom mail header used to contain a magic fingerprint string "unique" to a JIRA instance, used for
* identification purposes.
*/
public static final String HEADER_JIRA_FINGER_PRINT = "X-JIRA-FingerPrint";
Here is where the message comes from:
if (!fingerPrintHeaders.isEmpty())
{
...
if (fingerPrintHeaders.contains(instanceFingerPrint))
{
...
else
{
log.info("Received message with another JIRA instance's fingerprint");
}
}
Workaround
Do note that Atlassian do not support customization as described on the documentation as outlined in our Atlassian Support Offerings. Please only try if you are confident on doing so and we strongly encourage customers to perform the check on test environment first before applying to production.
If willing to create issue when another JIRA send to another JIRA's mailbox, it can't be achieved by JIRA's default setting.
- Workaround is to modify the code which removes your instance from Atlassian Support Offerings.
- If this issue is critical for your operations, a feature request ticket has been created at JRASERVER-44107 - To Be Able to Create Issues By JIRA Mail Handler Fingerprint. We would like to encourage you to cast a vote on that issue and share your use-case within the comments, as that has way more impact on our product development than most other efforts. Also add it to your watch list to get notified once it is implemented in a future version.