Jira server functionality fails with No space left on device error

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

All sorts of functionality in JIRA may fail once the disk runs on out space. The type of functionality that fails depends upon how the disks have been configured - for example:

  • JIRA may fail to startup
  • Items in the UI may be missing
  • Attachments cannot be uploaded
  • Reindexing may fail or perform very slowly

Depending on which partition is out of space (the JIRA-Home or JIRA-Install), JIRA will not be able to start up or items in the UI will be missing.

The following appears in the atlassian-jira.log:

Caused by: java.io.IOException: No space left on device
	at java.io.FileOutputStream.writeBytes(Native Method)
	at java.io.FileOutputStream.write(FileOutputStream.java:282)
	at java.io.BufferedOutputStream.write(BufferedOutputStream.java:1

Diagnosis

If this exception is thrown, it indicates there's a problem with disk space. Locate the JIRA-Home and JIRA-Install directories and verify the amount of space left on these partitions. Additionally ensure the database server has sufficient disk space available.

Cause

One of the two partitions, or the database server, is out of space, or does not have enough left for JIRA to operate normally.

Resolution

JIRA will not necessarily gracefully recover from a disk space outage, it is highly likely corruption will occur. Databases are hardened against this, however JIRA is not designed to be able to be run with insufficient space on the disk.

  1. Immediately stop JIRA.
  2. Hosting JIRA indexes ($JIRA_HOME/caches/indexes)  over network shares is not officially supported as per our Supported platforms. If using a remote network share please move this to a locally mounted drive.
  3. Allocate more space where the directories and/or database is located and restart JIRA.
  4. Restore the last known working backup from prior to the outage.
  5. Install monitoring for the disk space to prevent this problem from happening again.
Last modified on Sep 25, 2019

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