JIRA Issue status out of sync when viewed through the Issue Navigator

Still need help?

The Atlassian Community is here for you.

Ask the community

Symptoms

  • Issue status is not updated in the Issue Navigator.
  • When transitioning an issue between statuses, the status is updated correctly as seen on the View Issue page, but the status remains unchanged in Issue Navigator results.

Cause

The Issue Navigator results are based on indexes, so whenever a status or anything else is not matching up with what you are seeing on the individual issue view page it usually means that the indexes are out of sync with the database. This out of sync indexes could be due to a number of different reasons.

Workaround

  • Re-index JIRA

Resolution

  • Check the workflow transition which is failing to update the indexes and verify that the it has a post function which triggers a re-index for the transition.

  • If the post function triggering a re-index is in place, this could be caused by a failed condition, validator or post function in the transition causing the re-index not being triggered.
  • Eliminate each condition, validator or post function as the cause by removing them one by one from the transition.

(info) It is recommended to take a backup of the workflow prior to making any changes. In addition, please consider testing this on a development instance of JIRA or a test project.

Last modified on Feb 26, 2016

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.