JIRA Issues Do Not Need A Resolution

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Platform Notice: Cloud, Server, and Data Center - This article applies equally to all platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

JIRA Issues in your environment do not need a "Resolution" (yet), however, show as resolved.

If you do need to set a resolution, please check out Jira issues need a resolution.

Cause

  1. A Screen which has the Resolution Field

    1. Since Resolution is a Required Field, its Default Value is selected and applied when the screen is saved
  2. Resolution is set by a POST Function on a Workflow Transition
  3. Resolution is not Cleared when the Issue is "Re-Opened"

Resolution

Note, these steps would be used to remove the Resolution from Issues in your environment, however, does not prevent the Resolution from being set.  There are a few places to check:

  • If the Resolution is being set when an Issue is created or Edited, check the Screen being used and ensure that the Resolution Field is not present
    • If the Resolution Field is on a screen used for anything other than a "Resolve Issue" screen, the Resolution will be set to the Default Value (if not already set)
  • If the Resolution is being set during a Transition in the Workflow (for example: Open > In Progress), check that Transition for a POST Function that Sets the Resolution 


Clear Resolution and Preserve Current Issue Status:

To remove a value from the Resolution Field, add a POST Function which clears the field:

  1. Locate your Workflow: > Issues > Workflows
  2. Click Edit under Actions for your workflow
    • You may want to create a Copy to preserve the original Workflow or if your Project is using the JIRA system Default which cannot be edited
  3. Create New Transitions that loop back into the same Status; Open > Open
  4. On this New Transition:
    1. Click 'Add POST Function > Select 'Update Issue Field'
    2. Select Resolution for Issue Field and the NONE Field Value
  5. Publish Changes or Assign this workflow to your Project



Once created, you can use the Bulk Edit the issues and perform the Transition to Clear the Resolution

Clear Resolution When Re-Opening an Issue

  1. Locate your Workflow: > Issues > Workflows
  2. Click Edit under Actions for your workflow
  3. Select your "Re-Open" transition, and Click POST Functions
  4. Click 'Add POST Function > Select Update Issue Field
  5. Select Resolution for Issue Field and the NONE Field Value


Last modified on Mar 21, 2024

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