Jira/OpsGenie: Change OpsGenie notes to internal comments in Jira

Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

This article is about using automation to change OpsGenie updates in Jira automatically to internal comments if/when needed as currently when actions are performed on an OpsGenie alert it is sent back to Jira as public comments making them visible to portal customers.

Environment

Jira cloud integrated with OpsGenie.

Cause

Currently, it is not natively possible to add OpsGenie's comments in Jira as internal comments hence the article is created as a workaround for OPSGENIE-145: Ability to add a private (internal) note in Jira ticket when action is taken in Opsgenie

Solution

Use the steps below to configure a built-in automation rule to automatically convert those updates into internal comments that are not viewable by portal customers keeping in mind that the rule is intended to have the following behaviour:

  • When a comment is added.
  • If the user = Alert Integration.
  • Then the comment which triggered the rule will be changed to an internal comment.

Configuration details:

  • Go to Project Settings > Automation > Create Rule.
    • Trigger - When a comment is added:

    • User Condition - If the user who triggered the comment addition = Alert Integration:

    • Action: Edit trigger comment and change it's visibility to "Internal Only":

Important Note

Even though the comment added by OpsGenie user will not be visible to customers in portal if "Public comment added" and/or "Public comment edited" notifications are enabled under Project Settings > Customer Notifications customer will still get the notification.

If this behaviour needs to be avoided we suggest following the below possible workarounds:

Workaround 1 - In case customer's notifications are not needed

  • Clear the Request Type field which will prevent all notifications to portal customers.

Workaround 2 - In case customer's notifications are needed

  • Disable "Public comment added" and/or "Public comment edited" notifications under Project Settings > Customer Notifications by toggling the switch on the right side:

  • Modify the above rule as seen below to substitute system notifications for comments excluding notifications triggered by Alert Integration user (Or create 2 separate rules for comment addition & comment editing depending on the use case):
    • Trigger: When Issue Commented or Issue Comment Edited:

    • Condition: Add an If/Else Condition
      • If User Condition - If the user who triggered the comment addition = Alert Integration.
      • Action: Edit trigger comment and change it's visibility to "Internal Only".
      • Else/If User Condition - If the user who triggered the comment addition != Alert Integration.
      • Action: Send an email to All customers involved & Reporter with the below configuration:

Last modified on Jul 25, 2023

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