Jira/OpsGenie: Getting 400 Bad Request Specify an issue type error in Opsgenie


Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

A Jira issue is not created from an Opsgenie alert via the Legacy Jira Integrations.

Environment

  • Jira Software Cloud.
  • Jira Service Management Cloud.
  • Opsgenie.

Diagnosis

As per the Opsgenie Jira Software/Service Management Integration functionalities, one of the functions is to create a Jira issue in a project when an alert is created in Opsgenie.
However when an alert is created no issues are created in Jira, and we see the following error in the Activity Log of an alert:

Could not send [createIssue] action to JiraServiceDesk [JSM_Integration]. Reason: 400 Bad Request: "{"errorMessages":[],"errors":{"issuetype":"Specify an issue type"}}"

Cause

There is a typo on the Issue Type name provided in the Issue Type field.

Solution

Check the concerned Jira Project for all the available Issue Types and provide the correct name to the Issue Type Name field.

  1. Login to your OpsGenie site URL.
  2. Go to Teams > Integrations > Select Jira Service Management /Jira Software integration.
  3. Under the "For other Opsgenie alerts" section, provide a valid value for the Issue Type Name field:

  4. Click Save Integration.

In case you are still seeing an error in the alert Activity Log, please contact Support via Atlassian Support portal





Last modified on Aug 18, 2023

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