Jira page loading issue with the error ERR_HTTP2_PROTOCOL_ERROR thrown in the browser developer tool

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

   

Summary

Some Jira pages are either not loading or are very slow to load, and the error ERR_HTTP2_PROTOCOL_ERROR is thrown in the browser developer tool.

The impacted page(s) can be very random. So far, pages (or actions) that have been reported to be slow or not working are listed below (but not limited to):

  • a particular Jira issue view page (for example <JIRA_BASE_URL>/browse/<ISSUE_KEY) might not load at all
  • the deletion of a Jira release might take a very long time to complete

Environment

Any Jira 8.x version.

Diagnosis

  • Jira is configured behind a reverse proxy server where HTTP2 is enabled
  • When collecting a HAR file while replicating the issue, some HTTP requests will show a slow loading time (about 60 seconds), along with a 200 response code and the error ERR_HTTP2_PROTOCOL_ERROR:


  • Enter plugin safe mode via the page ⚙ > Manage Apps > Manage Apps and see if the issue goes away. If it goes away, then it is likely that an add-on is causing the issue. In this case, to identify which add-on is causing the issue, you can exit plugin safe mode, and then disable each add-on 1 by 1 until the issue goes way

Cause

Some 3rd party add-ons are known to cause this issue. The add-ons which have been reported to cause this issue are listed below (note that this list might not be exhaustive):

The exact reason why these add-ons are triggering the error ERR_HTTP2_PROTOCOL_ERROR is not entirely clear. Usually, this error is thrown by the browser if the browser detects that there is an invalid header in the HTTP request, and if HTTP2 is being used. Since the HTTP2 protocol is stricter than HTTP1, the browser will complain if any HTTP header has some invalid character (like a space for example). It is possible that by using any of the add-ons listed above, such add-on is adding invalid headers to the HTTP request.

Solution

Disable the problematic add-on. If the add-on is coming from a 3rd party vendor, please reach out to the vendor support team for further assistance.



Last modified on Oct 20, 2021

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