Jira Service Management stops processing emails
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
Jira Service Management Email Request functionality stop working
- No incoming mail are able to be processed
- In
Jira Administration > Applications > Email Request > Click on 'View Log'
, Connectivity log and Processing log is not showing anything (empty)
The following appears in the jira-incoming-mail.log
ERROR ServiceRunner [c.a.s.caesium.impl.SchedulerQueueWorker] Unhandled exception thrown by job QueuedJob[jobId=com.atlassian.jira.internal.mail.services.MailPullerJobRunner,deadline=1458744697361]
Diagnosis
Diagnostic Steps
- Incoming mail were working previously with no issue
- There are recent database / network interruption occurs recently
- Database restart have been done recently without shutting down Jira
Cause
Below services are stuck due to abrupt interruption towards Jira which lead to the mails are unable to be pulled. Looking at the Scheduled Jobs, the scheduled jobs seems to hangs and is not running (by referring to 'Next Run' date, compare with the real time of the server. The next run date/time will be backdated)
- com.atlassian.jira.internal.mail.services.MailProcessorJobRunner
- com.atlassian.jira.internal.mail.services.MailPullerJobRunner
- com.atlassian.jira.internal.mail.services.MailCleanerJobRunner
Resolution
Restart Jira to retrigger the scheduled service.
There is a corresponding feature request to allow the mail services to be restarted manually instead of restarting Jira: JSDSERVER-5397 - Restart JIRA mail services manually