Jira Service Management Automation Rules not working
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Problem
Users complain about automation rules not working. This "symptom" can stem from various different reasons. Please check the Diagnosis section to validate if this KB is indeed applicable.
Diagnosis
Identify the Project(s) and the Automation rule(s) not working
Go to Project Settings > Automation > Click on View log for the particular Automation Rule touted to be not working

Check for a record of the automation rule in the view log section. However, here there's no record of this automation rule even triggering
This is different from triggered but "NOT EXECUTED" or reporting an error. It'd appear as if nothing is recorded in the automation logs section on the UI
Check if the "Run as user" user has the required permissions to trigger the automation rule. Use Permission helper to validate
Cause
Service Management automation rule is not even triggered because the "Run as user" user doesn't have all the required permissions on the Project
Solution
Resolution
Add the necessary permission to the "Run as user" in the project permission settings.
Or Edit the rule from the options "Run as the user who triggered the rule". However, this would mean only users with required permissions on the project can trigger the automation rule.
Hint: Make sure the user has Browse Project permission on the project
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