Jira Service Management project displays unwanted customers in customer section
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
You notice there are some unwanted Jira Service Management customers displayed in the "Customer" section (Service project > Under Channels & People > Customers). In some cases, these users are internal users (ie. Users with/without a Jira license) that you don't want to be part of the current Service project.
Environment
Jira Service Management Cloud
Diagnosis
Unwanted customers/users are listed under the Customer page.
Cause
This behavior occurs due these customers/users are granted the Browse Projects permission to one of the groups that they are part of. By doing that, Jira Service Management considers them as customers and adds them to the Customer section in the Service project.
For instance: If user A (unlicensed Jira Service Management user) is part of the "Developers" group and granted Browse projects permission in the Service project, then users A and other users who are in the Developers group will be considered Jira Service Management Customers and will be listed in the Customer section.
Solution
You need to remove the specific group that the affected users are part of from the Browse project permission of the Service project. Follow the below steps to proceed:
- Navigate to Service project > Project settings > Permission
- Click on Actions > Edit permission
- Find Browse project permission > Click Remove > select desired group to be removed Remove the group (ie. select Group - Developers) > Remove.
This will remove the Browse project permission from the Developers group. Please keep in mind, that removing this permission will nullify the ability of this group of users to see issues on this project. In other words, users who are in the Developers group won't be able to view issues in the affected Service project anymore.