Edit of an issue throws Uncaught TypeError error in Jira Data Center

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

One of the following errors is thrown when trying to edit a JIRA Software issue (most common situation, but some other actions can cause this to be thrown as well):

1 2 3 Exception: Uncaught TypeError: Cannot read property 'fields' of undefined Resource: http://localhost:8080/s/en_US-3zh25n-418945332/843/2/75a983baf49a3c34be4b7da2703feb7d/_/download/contextbatch/js/greenhopper-rapid-non-gadget,atl.general/batch.js <http://localhost:8080/s/en_US-3zh25n-418945332/843/2/75a983baf49a3c34be4b7da2703feb7d/_/download/contextbatch/js/greenhopper-rapid-non-gadget%2catl.general/batch.js> Line: 620
1 2 3 Exception: Uncaught TypeError: Cannot read property 'html' of undefined Resource: http://localhost:8080/s/en_US-3zh25n-418945332/843/2/75a983baf49a3c34be4b7da2703feb7d/_/download/contextbatch/js/greenhopper-rapid-non-gadget,atl.general/batch.js <http://localhost:8080/s/en_US-3zh25n-418945332/843/2/75a983baf49a3c34be4b7da2703feb7d/_/download/contextbatch/js/greenhopper-rapid-non-gadget%2catl.general/batch.js> Line: 620

Cause

This can be caused by a third-party plugin

OR

a required field is not associated with any screen ("summary" for example is a recurrent situation).

Resolution

To troubleshoot the third-party plugin possibility:

  1. Browse through Administration > Manage Apps > Manage Apps and then click on "Enable safe mode" (this will disable all plugins).

  2. Check if the problem persists.

To troubleshoot the field possibility:

  1. Browse to Administration > Issues > Fields and then click on the Field configurations menu tab on the left side of the screen);

  2. Click on "Default Field Configuration".

  3. Check all of the fields that are set as "Required".

  4. Click on the "Screens" option for each Required field and check if these are associated with the "Default" screen.

Updated on April 8, 2025

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