Jira still sends notification after removing recipients from "Issue Closed" event
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
When an issue is moved to Closed status, the notification is sent to the recipients even if all the recipients are removed from the "Issue Closed" event in the Notification Scheme.
Diagnosis
Check the workflow associated with the issue type on the transition to Closed status.
- Go to your Project settings > Workflow > click on the pencil icon beside the relevant workflow to edit.
- Click on the transition going to Closed status > click on Post Functions tab > check the "event" that is configured.
- You will see it's configured with a Generic event.
Cause
It is firing a Generic event rather than an Issue Closed event. You have removed the recipients from the Issue Closed event; however, the event being fired was a Generic event (which still contains some recipients).
Solution
Follow the below steps to edit the workflow for the Issue Closed event:
- Go to your Project settings > Workflow. Click on the pencil icon beside the relevant workflow to edit.
- Click on the transition going to Closed status and click on Post Functions. You will see that it is set to a Generic event.
- Edit and set it to "Issue Closed" event.
- Publish the workflow.
Now, when you move an issue to Closed status, Jira will fire the Issue Closed event. Since it does not have any recipients, no mail notification will be sent to any user.