JIRA Throws NullPointerException When Navigate To Project's Issue Types Tab
Symptoms
- Multiple Issue Types Scheme are set as the default instead of only Default Issue Type Scheme.
The following appears in the atlassian-jira.log
:
jadmin 922x258x1 ws5lk 127.0.0.1 /plugins/servlet/project-config/ATL/summary [jira.projectconfig.contextproviders.SummaryContextProvider] Unable to load project summary panel
java.lang.NullPointerException
at com.atlassian.jira.issue.fields.config.manager.IssueTypeSchemeManagerImpl.getIssueTypesForConfigScheme(IssueTypeSchemeManagerImpl.java:276)
at com.atlassian.jira.issue.fields.config.manager.IssueTypeSchemeManagerImpl.getIssueTypesForProject(IssueTypeSchemeManagerImpl.java:247)
at com.atlassian.jira.issue.fields.config.manager.IssueTypeSchemeManagerImpl.getIssueTypesForProject(IssueTypeSchemeManagerImpl.java:252)
Diagnosis
Check if there any entry that is associated to non-existing project by running the following SQL on JIRA's database:
select * from configurationcontext where project not in (select id from project);
Check if there is a default configuration on the database:
select * from configurationcontext where id = 10000 and fieldconfigscheme = 10000 and customfield = 'issuetype' and projectcategory is null and project is null;
Cause
There is Issue Types Scheme(s) that is associated with project(s) that no longer exist. This is tracked in - JRA-29446Getting issue details... STATUS .
Resolution
Always back up your data before performing any modification to the database. If possible, try your modifications on a test server.
If any records are found with the first SQL query in the Diagnosis section, remove the record with the following:
delete from configurationcontext where project not in (select id from project);
If no records are found with the second SQL query of the Diagnosis section, please add the following:
insert into configurationcontext values (10000, null, null, 'issuetype', 10000);
- Restart JIRA