JQL Auto Complete is no longer working for individual users

Still need help?

The Atlassian Community is here for you.

Ask the community

Symptoms

  1. JQL Auto Complete does not work for some users.
  2. JQL Auto Complete is enabled in JIRA's General Configuration.
  3. JIRA was upgraded to 5.2 were JQL Auto Complete is no longer controlled on a per user basis

Cause

Prior to the release of JIRA 5.2 it was possible to set JQL Auto Complete on a per user basis. This is now a global configuration set in Administration > General Configuration.

After upgrading to JIRA 5.2, any user(s) that had JQL Auto Complete disabled will not be able to enable it again. This bug is already fixed since JIRA 5.2.10, and was being tracked here:  JRA-30873 - Getting issue details... STATUS

Resolution

  • Run this query against JIRA's database to identify if any users have JQL auto complete disabled:
select propertyvalue from propertynumber where id in(select id from propertyentry where property_key='user.jql.autocomplete.disabled');
  • If any rows return a value of '1' then JQL auto complete is disabled for certain users
  • Run this query to enable JQL auto complete for all users that have it disabled:
update propertynumber set propertyvalue='0' where id in(select id from propertyentry where property_key='user.jql.autocomplete.disabled');

(warning) Please make sure to take a backup of your data prior to making any changes on the database level.

 


Last modified on Feb 26, 2016

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.