JQL Search Not Returning Results for Dropdown Field Option

Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

When performing a JQL search for a dropdown field option, you may encounter the following error message:

  • "The option 'XYZ' for field 'Field_Name[Dropdown]' does not exist."

Environment

Jira Cloud

Cause


This issue occurs if there is a preceding space in the option within the dropdown field. For example, instead of the option being 'XYZ', it was entered as ' XYZ'. This leads to the option not being found during a search unless the space is included.

Solution

To resolve this issue, you can follow either of the two solutions below:

  1. Include the Preceding Space in the JQL Search:

    • When performing the JQL search, include the space before the option name by using quotes. For example, search for ' XYZ' instead of 'XYZ'.

  2. Edit the Field Option to Remove the Preceding Space:

    • Go to the custom field options and edit the option to remove the preceding space. This will allow you to search for the option without needing to include the space.

By following these steps, you can ensure that your JQL searches return the expected results without encountering the error message.



Last modified on Oct 28, 2024

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