JSM not showing OpsGenie On-call schedules under project


Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

When trying to see the Opsgenie On-call schedules on Jira Service Management projects, you can face the following message:

You’re not a part of any on-call schedules

Contact an admin, add a new team or browse on-call schedules to get started.

Cause

The user who's trying to see the On-call schedules in JSM was added to the rotations in Opsgenie, but the user was not added as a team member.

Within a Jira Service Management project's On-call tab, Jira users will only have visibility into the schedules of the Opsgenie teams they are also members of.

Solution

In Opsgenie, to add the user to a team, access the Team dashboard and click the Members tab. Then click Add Member and when you begin typing a user, they appear in the drop-down menu.

After adding the user as a team member, they'll be able to see the On-call schedules under JSM projects:



The following Feature Request was created to add the ability for users that are not members of the Opsgenie teams to see the schedules in JSM projects:



Last modified on May 1, 2023

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