Knowledge base articles cannot be displayed from the Customer Portal due to incorrect application link configuration
Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.
Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Knowledge base articles cannot be displayed/viewed in the Service Desk customer portal iframe:
- When using Chrome, a gray page is shown
- When using Firefox, a blank page with a wheel spinning indefinitely is shown
Environment
Jira Service Management Server/Data Center 3.0.0 and higher versions, integrated with Confluence Server/Data Center (any version).
Diagnosis
When checking how the application link to Confluence is configured on the Jira application side (via the page ⚙ > Applications > Application Links), we can see that an incorrect URL is used in the Display URL field. Basically, a URL which is not Confluence's Base URL is set in that field:
Cause
The Customer Portal uses the URL set in the Display URL's field to load the Knowledge Base article from Confluence and then populate the iFrame within the portal. If an incorrect URL is set in the Display URL field, the Customer Portal will try to fetch the Confluence page content from an incorrect URL, and will either return an empty page or an HTTP Error code in the iFrame, depending on the nature of the URL.
Solution
Ensure that both the Application URL and the Display URL fields are set to the right URL (which should be the Confluence Base URL):