Mail is not being retrieved from the SMTP or POP Server

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

JIRA is not creating issues or comments from email.

The following appears in the atlassian-jira.log:

JVM Input Arguments                           : -Djava.util.logging.config.file=/atlassian/jira/conf/logging.properties -XX:MaxPermSize=256m -Xms256m -Xmx768m -Djava.awt.headless=true -Datlassian.standalone=JIRA -Dorg.apache.jasper.runtime.BodyContentImpl.LIMIT_BUFFER=true -Dmail.mime.decodeparameters=true -Datlassian.mail.fetchdisabled=true -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -Djava.endorsed.dirs=/atlassian/jira/endorsed -Dcatalina.base=/atlassian/jira -Dcatalina.home=/atlassian/jira -Djava.io.tmpdir=/atlassian/jira/temp

Cause

The JVM argument -Datlassian.mail.fetchdisabled has been set to true, disabling all mail fetching functionality within JIRA.

(warning) Please be careful when changing this behaviour. If multiple JIRA instances are using the same mail servers, significant errors can occur.

Resolution

  1. Stop JIRA.
  2. Remove the -Datlassian.mail.fetchdisabled=true parameter from JIRA's JVM arguments, as in our Setting Properties and Options on Startup documentation.
  3. Start JIRA.
  4. Test to ensure the mail is retrieved.

Last modified on Nov 25, 2024

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