Messages being reprocessed multiple times by Microsoft/Office 365 JSM mail handler
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Problem
Multiple duplicated tickets are being generated by the Jira Service Management Office 365 custom mail handler; they are being created by the same email that was received.
Causes
The custom mail handler connection is in a legacy connection and displays the following warning:
Extracting the messages in the mail handler logs and checking their headers, they have the same Message-ID. To extract the messages access the JSM project > Project settings > Email requests > View logs > … > Download raw email message.
Resolution
To fix this problem, disconnect and re-connect the mail handler using the OAuth method. If you are experiencing any issues, please reach out to Atlassian support here.