Missing Attachment section in JIRA Issue View

Still need help?

The Atlassian Community is here for you.

Ask the community

Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

The attachment section in the JIRA Issue View is missing. 

Cause

The com.atlassian.jira.jira-view-issue-plugin:attachmentmodule pluginkey is set to false in pluginstate table during an upgrade.

Resolution

  1. Shutdown JIRA

  2. Run the following query to identify the status of the pluginkey:

    SELECT * FROM pluginstate WHERE pluginkey = 'com.atlassian.jira.jira-view-issue-plugin:attachmentmodule';
  3. If the pluginenabled is false, set it back to true

    DELETE from pluginstate WHERE pluginkey='com.atlassian.jira.jira-view-issue-plugin:attachmentmodule';

    Always back up your data before performing any modification to the database. If possible, try your modifications on a test server.

  4. Restart JIRA

Last modified on Apr 5, 2020

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.