Missing 'Plugins' Link in Administration Console


The 'Plugins' link (Administration -> System -> Plugins) is missing after upgrading to 4.3 or later version.


The cause is a known bug that has been fixed in JIRA 5.0.5,  JRA-24218 - UPM doesn't get enabled on upgrade to 4.3 Resolved

JIRA 4.3+ bundles the Universal Plugin Manager and uses it to manage all bundled and extension plugins. Normally, we may see the above scenario when one has installed and disabled UPM Plugin in the old JIRA instance (before 4.3) and then upgraded to 4.3 or a later version.


Always back up your data before performing any modifications to the database. If possible, test any insert, update, or delete SQL commands on a staging server first.

  1. Stop JIRA.
  2. Run the following SQL against the JIRA database to re-enable the plugin:

    delete from propertystring where id = (select id from propertyentry where property_key='jira.plugin.state-.com.atlassian.upm.atlassian-universal-plugin-manager-plugin'); 
    delete from propertyentry where property_key='jira.plugin.state-.com.atlassian.upm.atlassian-universal-plugin-manager-plugin';
  3. Start JIRA and test to see if the UPM is accessible.

If there are any problems with the SQL update, please rollback JIRA to the backup immediately so as to avoid any possible data integrity issues.

Was this helpful?

Thanks for your feedback!

Why was this unhelpful?

Have a question about this article?

See questions about this article

Powered by Confluence and Scroll Viewport