Monday.com to Jira migration does not import all users

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

Sometimes users who are migrating their data from Monday.com to Jira Cloud may witness a situation where some or none of their users are migrated to Jira.

Environment

Jira Cloud

Diagnosis

These users may already exist in Jira Cloud, but imported entities like Comments on Jira Issues may still show them as "anonymous".

Cause

The role granted to the user on Monday.com does not align with the permissions granted to the user on Jira. Most likely, the user has been granted an admin role on Monday.com, but not on Jira.

Solution

Check the Groups the user is a member of in admin.atlassian.com.

  1. If the user is a member of an admin group like "site-admin" or  "jira-administrators" groups, grant them an admin role in Monday.com

  2. However, if a user is only a member of the "jira-software-users" group on Jira, assign them a "viewer" role on Monday.com before importing the data

Please see the attached screenshot:

User Management on Monday.com

Updated on March 14, 2025

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