Multiple Users Created when Importing from Trac for Each Different Email Address
Symptoms
For every email addresses used for users in Trac will be imported as a user whether the email addresses are for same user in Trac or not.
Cause
The importer plugin can't differentiate whether any email address is actually for any same user. It will consider every email address as a different user.
Workaround
Perform a process like search and replace in Trac database updating all the required email addresses to only 1 email address.
There's a python script developed by a customer - fix_trac_db.py that can help in achieving this (A lot of thanks to Henry Hughes).
This script is not maintained by Atlassian. Last revised is on February 2013.