Not able to create issue via this Service Management error

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Symptoms

Creating an issue through a Service Management fails, and the following message appears on the screen:

Diagnosis

Check the log files of atlassian-jira.log or catalina.out for details.  If you happen to see the a message like this one:

2013-10-08 10:49:46,822 XXXXXXX ERROR sysadmin 649x10928x1 mibv2 XX.XXX.XXX.XXX,XXX.XXX.XX.XXX /servicedesk/customer/ssd/create/get-it-help [atlassian.viewport.fields.FieldValidator]  [assignee] The default assignee does NOT have ASSIGNABLE permission OR Unassigned issues are turned off.

Then we know something is preventing Jira from using that specific account as the assignee.   However there are a few different possible causes here because Service Management has some added constraints.

Cause

For the example error mentioned in the Diagnosis section, we know to either grant the 'Assignable User' permission to the default assignee or allow Unassigned issues in the General Configuration.  Those steps should be checked first.  

However with Service Management, it is possible there is a 3rd restriction that can cause this error that is not as clear.  The user could be assigned the correct project permissions, and you could have the system setup to allow unassigned issues, but Service Management has other requirements in regards to assigning issues to Jira Service Management Agents.  If that is the limitation here, the Permission helper will provide more information on this with a summary such as "Jira Service Management has overridden permissions".

In that case it will be necessary to make sure that the user in question is also a member of the "Service Desk Team"  Role for that project in question.  If the user is not, then Service Management still will not allow you to assign the issue to that user.  Please note that this user needs to also have Jira Service Management application access first (which in turn consumes 1 Agent license seat for Service Management).

Resolution

  1. Use the Jira Permission Helper - Atlassian Documentation to see what permissions this user has.  This method will tell us exactly why that user cannot be assigned this issue.
  2. Adjust the permissions/general configuration so this problem will not occur.

 

Last modified on Nov 23, 2020

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