Not able to transition ticket on the Portal - You can not make this transition
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
You can show transitions in the portal so customers can transition requests themselves. When trying to transition issues on the portal, they can face an error message: "You can not make this transition".
Cause
The error happens because the status of the issue on the portal has been changed. It can be related to automation rules which transition the issues when customers add comments:
- Legacy automation rule
- A4J Automation rule
When the customers add a comment, the automation rule transitions the issue, but it's not reflected on the Portal instantly. If the customer tries to transition the issue right after adding a comment, the error message appears.
Solution
Refreshing the issue page on the Portal will update its data to the latest version, and the customers should be able to transition the issues.