Not able to view and configure Jira Service Management project settings as a site admin
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Problem
As an administrator of the Jira site, when trying to configure a Jira Service Management project, trying to access a Jira Service Management-specific configuration page (E.g: Customer permissions, Request types, Portal Settings, Email requests) comes up with the 'Something's gone wrong' error.'
Cause
Your account does not have the required permission to access and configure the Jira Service Management settings in the project. This can be due to:
- Your account not having product access to Jira Service Management. To be able to manage and configure service management features, your accounts needs to have product access to Jira Service Management.
- Your account not being added to a project role that provides sufficient permissions to administer and access Jira Service Management features of a project.
Solution
Check your account's product access
To be able to access and administer Jira Service Management features, make sure that your account has product access to Jira Service Management. If your account does not have JSM product access, either add your account to a group that grants product access to Jira Service Management.
Add your account to the correct project role(s) in the project
Company-managed Projects
Under Project Settings → People, add your account to a project role that grants Service Agent Permission (Under the project's permission scheme) in a project type. In most cases, this should be the Administrator project role, so we recommend adding your account to this role.
Team-managed Projects
Under Service Project Settings → Internal access, add your account to the Administrator role