Notification emails don't contain correct From address

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Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.

Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Notification emails received by users are all from the same "person" when you look at the From address. This address is generally that of the outbound emails for that project.

Diagnosis

Check your email headers and see if the Reply-To is correctly set.

Cause

This is actually caused by Outlook + Exchange + AD, not JIRA. Outlook clients only on Windows try to compare the From name with the email address, if they don't match what's in the Global Address book, it strips off the name and only displays the (JIRA) jiraoutgoingemail@example.com in the view of the email. 

Resolution

To work around this issue, you must allow the host that JIRA is sending emails from to be trusted without authentication. Then remove the Active Directory jira user from authenticating in the outgoing mail server.


Last modified on Dec 30, 2024

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