Notifications not sent on Resolved or Reopened Requests in JSM

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Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Problem

When a Service Management request is resolved or reopened, the Reporter is not notified. The logs show no errors.

(info) A request is considered Resolved if a value is set in the Resolution field, for example during a transition.

(info) A request is considered Reopened if the Resolution field is cleared, for example via a post function.


Diagnosis

  1. You have already gone through all the basic troubleshooting steps in the Resolve customer notification issues in JSM Cloud knowledge base article.
  2. The Reporter receives all other notifications, such as when a Request is created, commented on, or when they are added as participants. 
  3. You are setting the Resolution of the request as a Workflow Post function, instead of via a screen with the Resolution field in a transition.

Cause

As detailed in the Managing Service Management Notifications documentation, a notification for resolved/reopened is sent if:

  • the request is resolved with a set resolution field
  • the request is reopened with a cleared resolution field

What this means is that the Resolution field must be set to a certain value before the transition itself occurs. Taking a look at a typical example set of post functions for a transition:

  1. Set work item status to the linked status of the destination workflow step.
  2. Add the comment to the work item if one is entered during the transition.
  3. Update change history for the work item and store the work item in the database.
  4. The Resolution of the work item will be set to Successful.
  5. Re-index the work item to keep indexes in sync with the database.
  6. Fire a WorkItem Closed event that can be processed by the listeners.

By referring to steps #1 and #4, here we can see that the issue is being transitioned to the next status in Step #1, but the resolution is only set in Step #4. 

This means that the Resolution is being set AFTER the transition, and no notifications will be sent. 

Correct order of Post functions

The post function for setting the Resolution field must occur before the post function for changing the work item status.

  1. The Resolution of the work item will be set to Successful.
  2. Add the comment to the work item if one is entered during a transition.
  3. Update change history for the work item and store the work item in the database.
  4. Set work item status to the linked status of the destination workflow step.
  5. Re-index the work item to keep indexes in sync with the database.
  6. Fire a Work Item Closed event that can be processed by the listeners.


Last modified on May 8, 2025

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