On a Team- managed project, re-naming a status and re-using that status name, does not let us save the changes.

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Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

On a Team- managed project, changing the current name of a workflow status and re-using that name on a new status in the same workflow, does not let us save the changes. Error will be seen as below:

Environment

Jira Software Cloud - Team Managed projects

Diagnosis

Steps to reproduce:

  • For example, within a workflow of a Team managed project, change the name of the status from "Backlog" to "Start"
  • Create a new status and name it "Backlog", configure transitions. Save the changes. 
  • The changes do not save and we see the error: "We couldn't save your changes" 

The browser dev tools will show the below error:

{"elementType":"STATUS","elementId":"xxxx-xx-xxx-xxx","message":"Status with id xxxxxx-xxx-xxxx-xxxx has the same name with an existing status: xxxxx-xxxx-xxxx-xxxx","errorCode":"STATUS_RENAMED_TO_EXISTING_STATUS"}

The status ID's from the above message can be used to verify the statuses that have conflicting names from 'Request payload' section of the browser dev tools: Network> Error> Headers> Request Payload.

Cause

Both the changes made at once on the workflow, before saving them. 

Solution

Save each change before proceeding to the next one. Once the Status is renamed, save this change. Then proceed to create a new Status and use the previous name of the now re-named Status, save. The changes will be saved without any error. 




Last modified on Sep 9, 2021

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