Only JIRA Administrator Can Login to JIRA
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.
Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
When JIRA is configured with Crowd, only users in JIRA Administrators group can login to JIRA. Problem could happen after upgrading to JIRA 7 from JIRA 6.
The following appears in the atlassian-security.log
2016-07-08 10:03:38,638 http-bio-443-exec-6 anonymous 603x132x1 s2xmeb 106.116.62.11 /rest/gadget/1.0/login login : 'vshanmugam' tried to login but they do not have USE permission or weren't found. Deleting remember me cookie.
2016-07-08 10:03:39,295 http-bio-443-exec-6 anonymous 603x132x1 s2xmeb 106.116.62.11 /rest/gadget/1.0/login The user 'vshanmugam' has FAILED authentication. Failure count equals 3
Diagnosis
- Obtain the LDIF file of the user who is unable to login.
- It's likely that the user is associated with jira-user group.
- From the LDIF file, check whether the user is associated to group such as jira-software-users.
Cause
Non admin users were unable to login to JIRA because of the changes in group in JIRA. In JIRA 7, there an additional jira-software-users group.
Resolution
To allow the non-admin users to login to JIRA:
- Login to Crowd and check the Specify which users can log in to JIRA configuration and check whether both {{jira-users}} and {{jira-software-users}} is added to the permitted group.
- If the jira-software-users or jira-users group is missing or inactive, add both of the groups in this screen :
- Re-sync your Crowd Directory from JIRA and try to login with your regular username again.