Opsgenie not receiving heartbeat emails due to case sensitivity

Still need help?

The Atlassian Community is here for you.

Ask the community


Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

Opsgenie will not receive emails if the email address you are sending the alert to has a different case than the Heartbeat email address.

Environment

Opsgenie Cloud 

Diagnosis

To verify if the problem is due to the casing of the email address used, you can follow the below steps:

  1. In your instance's Opsgenie, go to Settings > Heartbeats.

  2. Click on the Heartbeat that's not receiving the alert, and look at the case of the designated email address made from the Heartbeat's name which you can use to send to Opsgenie.

  3. Verify if the case of the heartbeat's name is the same as the case of the email address that you are sending the alert to. 

  4. You can also verify that this is the issue by going to Settings > Logs, and you'll find a Warning with the below message:

    com.opsgenie.heartbeat.exception.HeartbeatPingFailedException: Can not ping heartbeat [<heartbeatname>]. Possible causes: - Heartbeat does not exist or is not enabled

Cause

This issue happens if the alert is sent to an email address that has a different case than the designated email address made from the Heartbeat's name.

For example, the Heartbeat name is created with a mixture of uppercase and lowercase (e.g. MyTestHeartbeat@domain.heartbeat.opsgenie.net. However, the email delivery service is sending the alerts to the email address with all lowercase (e.g. mytestheartbeat@domain.heartbeat.opsgenie.net). Opsgenie recognizes mytestheartbeat and MyTestHeartbeat as two different heartbeats (case sensitive), and wouldn't find mytestheartbeat because it doesn't exist.

Solution

  • Make sure that the alert is sent to the email address made from the Heartbeat's name with the correct case.

  • (Suggestion) Use all lowercase in the Heartbeat's name because we've seen some example of email delivery service that forces the recipient email address to lowercase.


Last modified on Apr 19, 2024

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.