Options to disable bundled Insight plugin in Jira Service Management - Data Center
Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.
Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Since Insight is now bundled plugin with Jira Service Management Data Center 4.15.X and above, we see an option for Insight under our main menu options in Jira user screen.
As many customers are not using the Insight plugin for their use case and the option is available by default in the menu options, we would like to disable Insight and remove the Insight from the available options in the main menu as it is redundant to avoid any confusions to our users. It also helps use other plugins effectively without any issues.
Environment
4.15.X and above versions of JSM Data Center.
Diagnosis
Sharing few of the methods to manually disable Insight plugin though backend as it's no more a user-installed plugin. However, we don't recommend you disabling the application because of the following reasons:
- Insight Asset Management is bundled with Jira Service Management (JSM) as a core part of the product. We continue to deepen the integration of Insight with JSM and do not have plans to provide the ability to disable the feature.
- Insight provides powerful asset and configuration management capabilities that lets you create and manage your IT and business assets, and interact with them through requests, incidents, changes, and more. Whether it’s hardware, software, or office equipment, you can see everything you own at a glance and categorise it in a clear way. These capabilities are a cornerstone of IT Service Management (ITSM), a market where we continue to see strong momentum.
- We had a similar feature request in the past which was not considered owing to above reasons. Reference: JSDSERVER-7366 - Option to disable the recently bundled plugins like Insight, Advanced Roadmaps for users in GUI (if they don't prefer to use them)
Research Done
All the approaches have been tested in fresh JSM DC instance and work effectively.
Cause
Insight is now bundled plugin with Jira Service Management Data Center 4.15.X and above versions and users don't have an option in the GUI to disable it when not used. By default it will also populate an option in the main menu for users when they have access to Insight object schema as part of the role.
Solution
1. Disable the access of Insight applications to users as part of the roles (Best approach):
- Being Jira system administrator you need to access "Insight → Configure" option.
- Goto roles and remove all the users and groups from the roles. You can also restrict the access to only few users, groups based on requirement.
- This will remove the access of users from accessing Insight and this option is not available for users in GUI. (Jira system admins still have this option enabled and they can control based on need).
- No restart needed for this operation and this is a best possible solution to stick to best practises (screenshots attached for reference).
2. REST API Based Approach:
You need to make a PUT call to the REST API point mentioned below:
/rest/plugins/1.0/com.riadalabs.jira.plugins.insight-key
The API request needs to have HEADER variable "Content-Type" set as below.
Content-Type: application/vnd.atl.plugins.plugin+json
Finally the BODY of the PUT call needs to have below JSON content.
{"enabled":"false"}
Complete REST call reference which you can make use of running in command line (replace the values of JIRA_USERNAME, PASSWORD and JIRA_BaseURL based on your system values).
curl -u <JIRA_USERNAME>:<PASSWORD> -X PUT -H "Content-Type:application/vnd.atl.plugins.plugin+json" -H "X-Atlassian-Token:no-check" -d '{"enabled":"true"}' "<JIRA_BaseURL>/rest/plugins/1.0/com.riadalabs.jira.plugins.insight-key"
- No restart of Jira required for API related changes, once you refresh your browser session you now should have Insight disabled.
3. Manually Database Update Approach:
Ensure to take database backup before making any changes, though we are not deleting anything here. These queries are tested against Postgres Database and should work with others as well with some modifications. However, logic remains the same irrespective of the database service being used.
Access the database and execute the below query: Check if table has value for "com.riadalabs.jira.plugins.insight" plugin entry with "pluginenabled" column set to true (if yes, then we need to set this to false using second "UPDATE" query to meet our requirement).
SELECT * FROM "pluginstate" WHERE pluginkey='com.riadalabs.jira.plugins.insight'; UPDATE "pluginstate" SET pluginenabled='false' WHERE pluginkey='com.riadalabs.jira.plugins.insight';
If the "pluginstate" table doesn't have the entry mentioned above, we need to INSERT one using below query to meet the requirement (when you want to re-enable just set "pluginenabled" column value to "true").
INSERT INTO pluginstate (pluginkey, pluginenabled) VALUES ('com.riadalabs.jira.plugins.insight','false');
- This will add an entry to "pluginstate" table to indicate the application that this plugin has been disabled.
- Restart Jira for changes to be effective (since these are database updates), you now should have Insight disabled.
Based on your preference and comfort with operations, you can use one of the solutions to ensure Insight is disabled and the icon will no more appear on the Menu options for users.
Try the suggestions and we believe it should help meet your requirements.