Pie Chart shows "Irrelevant" category in the chart

Still need help?

The Atlassian Community is here for you.

Ask the community

Platform Notice: Cloud, Server, and Data Center - This article applies equally to all platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

When configuring a pie chart and selecting a field in the "Statistics Type" parameter (eg. selecting a "Status"), the resulting pie chart contains a category "Irrelevant", but the source field does not contain this data (e.g. there is no issue with status "Irrelevant").

Cause

  1. There are multiple custom fields with the same name as the one picked up in "Statistics Type" or with the name duplicating those of a standard Jira field. For example, there might be a custom field with the name "Status", and this is what is getting picked in the pie chart configuration instead of an issue status. Generally, "Irrelevant" category in statistics widget appear automatically if issues in the configured filter do not have any data for the statistics type selected.
  2. The relevant field has been hidden in the project's Field Configuration scheme

Workaround

Cause 1
Examine all available entries in the "Statistics Type" field and pick up another entry with the same name. Note that the entries are not alphabetically sorted (this is a known issue JRASERVER-61819 - Getting issue details... STATUS ).

Resolution

Cause 1
Rename conflicting custom fields and make sure their names do not duplicate each other or those of standard fields. When each field has a unique name, picking it up in the "Statistics Type" is easy, as it should be possible to just type in the full custom field name in the selector to make it select it automatically.


Cause 2
Unhide the relevant field from the project's Field Configuration scheme.





Last modified on Sep 15, 2023

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.