Problems when adding a new language in Language Support settings
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
When you add a new language (For example, Finnish/ German or any other language) in the Language support, it gives an error:
" We had a problem preparing your translations
An error occurred accessing the a plugin module"
Environment
Jira Service Management cloud
Diagnosis
Below information can be found while looking at the affected project.
The language support page for newly added languages (ie. Finnish) will not be accessible. But if you added the English (US) language, it works.
Once EN-US is added, under Language Support, you will see "1 section needs review" (in some cases it could be more than 1 section) besides the added language even if the UI does not show any pending translations (no yellow dot beside any category).
Errors seen in browser Developer Tools:
{errors: [{errorMessage: "An error occurred accessing the a plugin module"}],…}
errors: [{errorMessage: "An error occurred accessing the a plugin module"}] reasonCode: "500" reasonKey: "An error occurred accessing the a plugin module"
Cause
Sometimes some categories like "Portal content", "Components", and "Customer visible status" don't get reflected under Language support. They either appear empty or are not shown at all. This is a known bug that is being tracked in JSDCLOUD-9553 - Getting issue details... STATUS
The issue is usually seen with Service projects that are created using the option of "Share settings with an existing project".
Solution
Adding a space beside any of the "Portal content", "Components", or "Customer visible status" and then saving, will trigger these to start getting reflected under Language support with a yellow dot beside them so that we can add the pending translations.
To fix it, please follow the below steps:
- Go to the Project Settings of affected Project.
- Request types > Select a Request type > Workflow statuses.
- Change an existing 'Status name to show customer' value, by adding a trailing space (don't worry the space gets trimmed while saving so nothing really is changed) and save. This will re-trigger the translations.
- Go to language support settings and it should be accessible.
Other Notes
For more information, please visit Translate resolutions, priorities, statuses, and issue types.