Project import fails with field does not exist error in Jira Server and Data Center

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Platform notice: Server and Data Center only. This article only applies to Atlassian products on the Server and Data Center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Project import fails on custom field configuration. You might see the error message like this:

The following appears in the atlassian-jira.log:

2013-11-20 12:43:58,935 JiraTaskExectionThread-50 INFO admin@admin.com 763x5802x1 18uko72 127.0.0.1 /secure/admin/ProjectImportSummary!reMapAndValidate.jspa [jira.imports.project.DefaultProjectImportService] Project Import: Validation errors were found. The import cannot continue.
2013-11-20 12:43:58,935 JiraTaskExectionThread-50 ERROR admin@admin.com 763x5802x1 18uko72 127.0.0.1 /secure/admin/ProjectImportSummary!reMapAndValidate.jspa [jira.imports.project.DefaultProjectImportService] The custom field 'Epic Color' of type 'Colour of Epic' is required for the import but does not exist in the current JIRA instance.

Or seeing this error message:

  • The custom field 'Epic Name' in the backup project is of type 'Name of Epic' but the field with the same name in the current JIRA instance is of a different type.

Diagnosis

Compare the language settings across the two instance. Most probably they are using different language settings under Administration >> General Configuration >> Internationalization

  • English (United States)
  • English (UK)

Cause

The difference of letter 'u' in Epic Color and Epic Colour causes JIRA to think that there are 2 different custom fields. This is currently tracked in  JRA-35937 - Getting issue details... STATUS

Workaround

  1. Rename the custom field(s) on the target instance so that they matches on the previous server via Custom Field page. You can use this guide to do so. 
  2. If the custom field is locked, unlock it first using the guide here - How to unlock a Locked field.

(info) If you are importing into a new instance, make sure the language settings are correctly configured. You can check by clicking the (...) button > choose "Translation Details" and select the language settings below:

  • English (United States)
  • English (UK)

In the field name, please ensure the value is matching the right custom field name.

(info) Some users have also experienced similar errors when importing custom fields due to trailing white space in custom field names. If you're getting a similar error, double check that your Custom Field names align exactly between the two instances.

Last modified on Oct 2, 2024

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