Projects and Request Types Not Visible in Assist App Home
Summary
When Customers use Assist Bot in Slack and choose 'Raise a Request' option, some Projects and Request Types are not visible. Additionally, if only one Project is linked to Assist, Ticket Creation may not work through Assist App Home.
Environment
JSM cloud
Diagnosis
- Trigger the Assist Bot (either by clicking on 'Raise a Request', or by using the /assist command)
- View the dropdown with available Projects and Request Types.
Solution
The issue may occur if the "Hide project during issue creation" option is enabled under Project Settings → Channels & Self Service → Chat → Settings. When enabled, this option hides the project when users attempt to create a ticket outside of a Request Channel. To resolve this, follow the path above and disable the "Hide project during issue creation" option under the Settings section.
Further reading: