Quick Search Issue Fails
Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.
Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
Using the quick search box for issue fails
- proper format has been entered eg: QAL-2345
- Instead of opening a specific issue, the search will be performed in the Issue Navigator and no results will be returned.
Cause
- The project key format is improperly configured.
- For details on configuring the project key format, see here: Changing the Project Key Format
Resolution
Follow the steps listed below:
- Login as admin account
- Go to
JIRA Administration > System > General Configuration > Click the Advanced Settings Button
- Search for jira.projectkey.pattern
- Ensure that the pattern is properly configured
- Ex:
([A-Z][A-Z_0-9]+)
- Ex:
- Retest