Read-only Insight custom field not being updated


Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.

Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

 

Summary

Insight Readonly Object/s custom field does not get updated within a Workflow transition. It should be changed or populated based on an update triggered by a Workflow.

Environment

Insight - All versions

Diagnosis

  • Insight Readonly Object/s custom field is added to a Workflow transition 
    OR
  • Insight Readonly Object/s custom field depends on another Insight Custom field added to Workflow transition
  • Insight Readonly Object/s does not get updated after issue Created or issue Updated events

Cause

In the Workflow transition, you use the "Generic Event" instead of "Issue Updated". 
Insight Readonly Object/s custom field will only be triggered with Issue Updated event

Solution

Edit the Workflow transition and change from "Generic Event" to "Issue Updated".




Last modified on Feb 22, 2022

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