Receiving error in JQL search : "The option 'XXX' for field 'XXXXX' does not exist"
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
Running a JQL search using a field(For example: project = <Project Key> and "select list[Dropdown]" = A) throws an error The option 'XXX' for field 'XXXXX' does not exist.
Cause
This error appears when two or more custom fields with the same name are created in the Global Custom Field screen as well as in any Team Managed Projects.
Solution
You can use one of the following two ways to get the desired custom field in JQL:
- Use the Custom Field ID in Advanced JQL like : cf[xxxx] = "value"
- Change the Custom Field Name of the Global custom field or that of Team-Managed custom field. To access the list of global custom fields, navigate to Settings(cog wheel) > Issues > FIELDS > Custom fields
Fields in team-managed projects are contained within the project itself and the field cannot be searched from Global Custom Fields page or using JQL. Refer to Fields in Team Managed Projects
In order to identify which Team Managed Project using the same custom field name, please follow the below steps:
- Use Get Fields API in Browser. Example : https://your-domain.atlassian.net/rest/api/3/field, Paste the URL in the browser and Hit Enter.
- Copy the complete output and use JSON Viewer online Beautify tool to make it a Tree Structure.
- Search for the Field that does not appear in the Global Custom Field section. You will find the field with the format (sustomfield_XXXX)
- Copy the XXXX value from the above result and replace it in this link : https://your-domain.atlassian.net/secure/admin/ConfigureCustomField!default.jspa?customFieldId=XXXXX
- Paste the above-updated link in the browser URL and press Enter. This will show the Context and default value of the field with the Team Managed Project where the field is associated.
- You can then navigate to the respective project and Issue Types and change the Custom Field Name.
In case the issue is still not resolved, feel free to contact Atlassian support.