Remove non-required groups from Product Access in Jira Cloud

Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

By default, certain groups, such as administrators, site-admins, and jira-servicemanagement-users (or jira-servicedesk-users for older instances), are granted Product Access to Jira Service Management. However, if you have administrators who don't require an agent license, you may prefer to retain their admin status while ensuring that they don't consume any agent licenses.

Problem Description

Administrators are granted product access to Jira Service Management by default.

Root Cause

For Jira and Confluence Cloud, it's required to have one Default group to grant access to a product, but it's possible to add several groups that would also grant access to the products.

Resolution

Original user management

  1. Go to the Cog icon > User Management > Product Access.
  2. Choose the group which does not require the Product Access.
  3. Click on More options (three dots •••) and select Remove group.

A screenshot of the Product access page pointing the location of the meatball menu

Centralized user management

  1. Go to admin.atlassian.com and select your Organization.
  2. Click on Products > Manage Product next to Jira Service Management.
  3. Click on More options (three dots •••) and select Remove group from product.

A screenshot of point where to remove the group on the centralized user management

In the Centralized User Management, you have the option to select the Customer role. This choice is beneficial as it does not count against the license limit.


Trusted users (Original user management only)

Trusted  users role give users more responsibility and access. These users will be able to install and configure new products on your site and invite new users themselves. It is not possible to remove Product Access for Trusted users. If a user is given a Trusted user role, the user would have Product Access to all products.

A feature request ID-6675 - Allow administrators to configure default groups for Trusted Users was raised to allow configuring Product Access for Trusted users. As a workaround, you can perform the below: 

  1. Change the user role from Trusted to Basic.
  2. Add the user to the groups which grant the user the required Product Access.

References



Last modified on Jan 27, 2025

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.