Renaming the Atlassian Assist bot user turns the Assist icon in a grey icon for Slack connect channels in Jira Service Management Cloud

Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

   

Summary

Slack customers can have channels connected to external companies to work alongside each other, as described on Use Slack Connect to work with other companies in channels. With this setting active, if the Atlassian Assist bot is renamed, the bot icon in the external company workspace turns in a grey color:


Cause


The cause seems to be cookies/cache from Slack causing this icon display issue.

To reproduce this behavior:

  1. Use Slack Connect to work with other companies in channels
  2. Then in your Slack directory go to the direct message with the Atlassian Assist app
  3. Access the About tab 
  4. Click Configuration 
  5. You'll be redirected to Atlassian Assist app in Slack settings, then go to Bot user section
  6. Change the name of the bot

Usually, the bot works as expected in the Slack directory of the integration, but in the external company directory connected the bot will change to a grey icon.

Solution


Knowing that it's a cookies/cache this can be resolved with a refresh of the Slack or clearing the cookies/cache from the browser (in case Slack is being used in the browser).

  • Slack desktop App
    • You can refresh Slack by using cmd+shift+r (if in a mac) or ctrl+shift+r (if in a windows)
  •  Slack in the browser
    • Refreshing the browser may not work, in this case it's recommended to clear cookies/cache

You can see the following video resolving the issue in Slack desktop App:

Last modified on Oct 17, 2024

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