Replacing the system field "Description" in order to have a custom Description field with a default value in customer portal request forms

Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.

Summary

The System field's default value cannot be changed at this time. You can work around this by following the instructions on this page for creating a replacement custom field.

Environment

Jira Service Management Cloud

Diagnosis

Jira does not currently support adding or editing default values for system fields, but we do have a Feature Request for it here:

Solution

The steps listed below can be used by the admin as a workaround to create a custom field with default values to be used in the request form for the request type:

  1. Create a paragraph custom field named "Issue Description" and set the default values for it. For more information, please visit Create a custom field. You can refer to the below sample screenshot:
  2. Now replace in the necessary screens the Description (system field) by the newly created Issue Description field. 
  3. Under Project settings > Request types, go to the Request form of the desired request types to add the Issue Description custom field as shown below:

  4. Changing the renderer of the new field in your project's field configuration to Wiki Style Renderer is an optional step that will enable the field to work with rich text:
  5. Once you make these changes, the request form in the customer portal will look as shown below:

Keep in mind that the Description (system field) is necessary for the processing of support requests received via email with a Jira Service Management mail handler, so you cannot remove it from the Request types being used for this purpose. This is mentioned in Choose a Request type for email requests

If you have any issues with the steps, please contact us via Atlassian Support.

Last modified on Nov 3, 2022

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.