Resolution field is showing different value after the issue is transitioned or closed
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
Summary
When setting the resolution value through a transition screen, the resolution field does not show the selected value but a different one after closing the issue.
Environment
Jira Cloud / Jira Service Management Cloud
Diagnosis
You selected "Done" (for example) as a Resolution field value while transitioning, but the issue is closed, it changed to another value (i.e. Declined)
Cause
There is a post function in the workflow transition that is setting the resolution value to a default one (like "Declined"). This overwrites the resolution value that is set through the transition screen while closing the issue.
Solution
You need to remove the post function from the workflow transition to prevent it from overwriting the selected value. Follow the below steps to remove the post function:
- Go to the Project settings of the desired project.
- Click on Workflow and choose the underlying workflow of the issue type that contains the transition with the post function.
- Click on the Diagram view and click the affected transition
Under Options, click on Post Functions
Find the post function that sets the resolution to the incorrect value (here "Declined")
Click on the Delete button next to the post function to remove it.
Click on Publish Draft > Publish to save the changes to the workflow.
After removing the post function, the selected resolution value will be displayed correctly in the resolution field when the issue is closed. For more information about workflow, please visit Configure advanced issue workflows.
Please review the history of the particular issue to determine if an automation rule has caused the status change. If so, you need to either disable the automation rule or update it as required.
To turn off an automation rule,
- Go to the Project Settings of the desired project
- Navigate to Automation and select it.
- Search for the rule that was observed in the history. Then, use the toggle button to turn off the rule.