Selecting an automation template from the library results in an error

Still need help?

The Atlassian Community is here for you.

Ask the community


Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

When you try to create an automation rule from the template library, it generates the "Error creating template - There was an unknown problem during template rule creation. It is likely that customizations within this Jira instance have caused the template default to be invalid. Please refresh the page and try again, or attempt using a different template" error message.

Causes

Some automation templates are configured using the Jira default statuses. If these statuses are not present in the workflows used in a project, the rule creation will fail and the error will be displayed.

Statuses used by each template:

  • "Resolve issues due to inactivity" uses the statuses "In progress" and "Resolved".
  • "When a customer comments on a closed request → then reopen the request" uses the status "In progress".

Resolution

To fix this problem, add the statuses "In progress" and "Resolved" to at least one workflow associated with the project. Once this is done, it will be possible to create automation rules using any template from the library.


For more information, please visit Work with issue workflows



Last modified on Apr 19, 2024

Was this helpful?

Yes
No
Provide feedback about this article
Powered by Confluence and Scroll Viewport.