Sender Field ('from') Displaying only Sender's Email on Received Notifications
Problem
JIRA e-mail notifications doesn't display the sender name.
The 'from' field only displays the account used by JIRA and there are no errors in the logs.
Cause
This may be caused by a transport rule in Microsoft Exchange 2003 and 2007.
Resolution
Contact your infrastructure network administrator and review you Exchange Server configurations. A transport rule may be set up for JIRA's IP address, making the wrong name display. There is a discussion on a third-party blog post that may be helpful: http://social.technet.microsoft.com/Forums/en-US/exchangesvradmin/thread/2eea741b-1c31-44f6-a6c4-cdea506600f9/