Service ID 'xxxxx' no longer exists
Platform notice: Server and Data Center only. This article only applies to Atlassian products on the server and data center platforms.
Problem
In the scheduler administration page, there is a lot of errors icon appearing under com.atlassian.jira.service.DefaultServiceManager group.
After expand we will see this:
com.atlassian.jira.service.JiraService:10200
Type: Runnable
Parameters: {com.atlassian.jira.service.ServiceManager:serviceId=10200}
Run mode: once per cluster
Schedule: 1 hour
Last Run: Thu Jul 30 17:44:45 MYT 2015
Last run duration: 5 milliseconds
Next Run: Thu Jul 30 18:44:45 MYT 2015
Message: Service ID '10200' no longer exists!
Diagnosis
Check on the service id by running the SQL command below via database:
select * from jquartz_simple_triggers where trigger_name like '%<Service_ID>%';
select * from jquartz_triggers where trigger_name like '%<Service_ID>%';
select * from jquartz_cron_triggers where trigger_name like '%<Service_ID>%';
select * from clusteredjob where job_id like '%<Service_ID>%';
If one of the table above doesn't return the service data, that means the service no longer exist in JIRA.
Cause
The service ID is missing or no longer exist in JIRA database.
Workaround
Always back up your data before performing any modifications to the database. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.
- Backup JIRA
Run the SQL command below to remove the service ID data:
delete from jquartz_simple_triggers where trigger_name like '%<Service_ID>%'; delete from jquartz_triggers where trigger_name like '%<Service_ID>%'; delete from jquartz_cron_triggers where trigger_name like '%<Service_ID>%'; delete from clusteredjob where job_id like '%<Service_ID>%';
Restart JIRA.